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Installation 

Who’s Next 3.0 is packaged as a standard Microsoft Installation Package (MSI).  In order to install this 
file, you need to have the Microsoft Windows Installer 3.0 or higher on your computer. 
 

 

Desktop Shortcut 
To begin installing Who’s Next 3.0 - Counselor/Receptionist component simply launch the 
WhosNext.Main3.Setup.msi file and follow the installation instructions.  Once the 
application is finished installing, you should see a Who’s Next 3.0 shortcut on your 
desktop. 
 

Installation Folder 
During the installation, you have the option to change the folder where Who’s Next? 3.0 is installed.  By 
default, the application will be installed in the Program Files directory. 

If you have local admin rights to the computer, then the software can be installed under the “All Users” 
profile.  If not, then the software will place shortcuts on the Desktop and Start menu for the current profile 
only. 
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Connecting to the Who’s Next Database 

The first time you launch Who’s Next the software will prompt you for the Data Source Properties.  This 
window allows you to enter the server location, database name and login credentials.   
 

 

1. Database driver: the only option in this list is SQL Server. 
 

2. Server Location:  Enter the name or IP Address of the 
server that is housing the database. 

 
3. Database Name: Enter the name of the Who’s Next 

database. 
 

4. Logon Security: If you want to connect to the server using 
the same username and password you used to log into 
your workstation then select Use Windows NT Integrated 
Security.  Otherwise select Use specific username and 
password so that you can key in that information. 

 
5. Server User ID: Enter the username that is to be used to 

connect to the database. 
 

6. Server User Password: Enter the password that is to be 
used to connect to the database. 

 
Options: This button will allow you to import & export your data source properties to and from an encrypted 
text file. 
 
Test Connection: Click this button to test the data source properties. 
 
Save: Click this button to save the data source properties. 
 
Cancel or Close: Click these buttons to cancel this window.  Performing these actions will close the application 
immediately. 
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Data Source XML File Location 
Once the data source properties are verified and saved, the information will be encrypted and stored into 
an XML file on your computer in this directory: 
 

C:\ProgramData\Blue Eon Solutions\_Settings\Whos Next\Options\Main 
 

 
 

Read/Write Permissions 
During the use of Who’s Next, the software will attempt to read and write data to XML files located in 
the directory above.  In order to do this, your Microsoft Windows account must have read/write 
permissions to this directory.  Otherwise the next time you launch Who’s Next the software will prompt 
you for the data source properties again. 
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Logging in as a User 

After you successfully install Who’s Next 3.0 and have entered the data source properties, the 
application will display a system login screen.  To successfully log in, you must enter a valid username 
and password. 
 

 
 

Login Options 
Clicking the Login Options link on the System Login screen will bring up a Login Options window.  This 
window offers 3 different ways to log into the system. 
 

 

 None: this option means you will be 
allowed to enter your own username and 
password. 
 

 Use my network login id: this option will 
read the username you used to log into 
your computer.  Just so long as this 
username matches your Who’s Next 
username, you will be allowed to log in. 

 

 Remember the last username and 
password used: this option will log you in 
as the last username that was used. 
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Select Role Type 
Who’s Next allows users to log in as a Receptionist or a Counselor.  A Receptionist can only see the 
Student Lobby window whereas a Counselor can see the Student Lobby and also their My Inbox window.  
Both role types can sign in/out students as well as perform other duties based on their permissions. 
 
If the user’s profile has been granted both role types then he/she will be prompted to select which role 
they want to log in as. 
 

 
 

Change Password 
Depending on how your profile is setup, the system may prompt you to change your password after you 
log in.  If so then you will see this window. 
 
Please note that Who’s Next does not require you to change your password after so many days, nor 
does it require you to enter a certain number of letters or numbers. 
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Select a Department 
Who’s Next allows users to have access to as many departments as necessary.  If a user has access to 2 
or more departments, he/she will be prompted to select which department they want to log into.  If a 
user only has access to 1 department then the software will select this department by default. 
 

 
 
 
 
  



12 | P a g e  
 

Main Switchboard 

The main interface for Who’s Next is made up of 3 different windows: the Counselor Switchboard, My 
Inbox and the Student Lobby. 
 

 
 

Counselor Switchboard 
The Counselor Switchboard is used to view every user (i.e. counselor, advisor) that is currently logged 
into the system.  This switchboard will display every department the user has access to and then every 
user that is logged into those departments.  Each user is color coded to show their availability. 
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Folder Colors 
The folders within the Counselor Switchboard are made up of 4 different colors.  Each color shows a 
different status for the user. 
 

 

This folder represents a department. 

 

A Green folder represents a counselor/advisor that 
does not have a student in their office. 

 

A Red folder indicates that the counselor/advisor is 
logged in but is unavailable. 

 

A Tan folder indicates the user is currently with one 
or more students. 

 

A Purple folder indicates the user is logged in as a 
Receptionist. 

Popup Menu 
Right-clicking on the Counselor Switchboard will give the user a popup menu that allows him/her to 
perform a few operations.  Below is one example of the items on the popup menu. 
 

 
 

 Unavailable: If the user is currently unavailable, then this option will tell the reason why he/she is 
unavailable and will also display the time he/she set herself as unavailable. 

 Send ‘[user]’ an instant message: This option will start a new chat session using the internal instant 
messaging component. 

 Set Counselor’s Availability As: This option will give the user the ability to set a counselor/advisor as 
Available or Unavailable.  This should be used only if a user forgets to set their status.  

 List Students in Counselor’s In-Box: This option will allow the user to peer into the selected counselor’s in-
box.  He/she will also have the ability to bring the student over to their in-box, if needed. 

 Remove All Students from Counselor’s In-Box: This option will remove all students that are currently 
assigned to the selected counselor.  *Note* this functionality should only be used by a system 
administrator and only if needed. 
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 Log Counselor Out of Database: This option will remove the selected counselor from the list.  This option 
should be used only if a counselor did not log himself out of the database properly.  *Note* this 
functionality should only be used by a system administrator. 

 Close This Menu: This option will close the popup menu. 

 

Student Lobby 
The Student Lobby window shows all students that are waiting to be seen by an counselor/advisor.  By 
default the students will be listed in order by the Date/Time In column.   
 

 
 

My In-Box 
The My In-Box window shows every student that has been assigned to a counselor/advisor within that 
particular department.  *Note* your current department will be listed at the top of this window in 
parenthesis. 
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Signing Students In 

 
Any user can sign students into the Student Lobby or My In-box by clicking on the Sign 
In button.   

 

 

Advanced Sign In 
When a user clicks on the Sign In button then, by default, the 
basic Student Sign In window will appear.  Clicking the down 
arrow to the right of the Sign In button will allow the user to 
sign a student in using the Advanced window. 

 
 

Basic Sign In 
When signing a student in simply enter the 
student’s ID number and click the Sign In 
button.  Depending on if you clicked the button 
from the Student Lobby toolbar or the My In-
box toolbar will dictate where the student gets 
signed into. 
 

 

New Student ID 
If the student’s ID number does not exist within the database then the software will prompt the user to 
create the student.  The only information that is required for the student is the first name, last name 
and student ID number. 
 

 
 
In order for the user to create a new student, the user must have the Students > Can Create Student 
permission for this department. 
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Advanced Sign-In Screen 
Who’s Next also has an advanced sign in screen that allows the user to enter who the student wants to 
speak with and what service(s) the student is coming in for. 
 
The Users tab will give a list of users that can be selected from while signing this student in.  Clicking the 
All Counselors Logged In radio button will refresh the list and only show the users that are logged in.  
Clicking the All Department Counselors radio button will show every user that has access to this 
department, regardless if they are signed in. 
 
The user can also type in a specific user in the Other text box. 
 
The Pager ID field allows the user to enter a pager number for the student signing in.  *Note* please 
note that this is feature is only for schools that are using an external pager/coaster system. 
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The Services tab will show all of the sign-in services for this department.  The user can check off multiple 
services while signing this student in.  If the service is not listed, then he/she can type in a service into 
the Other text box. 
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Assigning Students to a Counselor 

When a counselor is ready to see a student, users can drag-and-drop students from the Student Lobby 
to a folder in the Counselor Switchboard.   
 

 
 
 

 

Once a student has been assigned to the counselor, the folder for that counselor 
will change to a Tan color.  A number will also appear after the counselor’s name 
telling the user how many students are currently with him/her. 

 

Refresh Delay 
Due to a 60 second refresh delay, there is a chance that the student the user is trying to assign has 
already been assigned to another user.  To correct this problem, Who’s Next will perform a query to 
ensure the student is still available.  If the student is not available, the user will be given this error 
message. 
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Assigning a Student to Yourself 
A user can assign a student to themselves by clicking on a student from the Student Lobby and dragging 
him/her to the My In-box window. 
 

 
 
 

Sending a Student Back to the Lobby 
A user can send a student back to the 
Student Lobby by dragging the student from 
the My In-box window to the Student Lobby 
window.  When this is done, the application 
will allow the user to attach a note to the 
student for the receptionist to read. 
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Saving Student Visits 

 
When a user is finished speaking with a student, he/she should sign the student out 
immediately.  To do this, select the student from the Student Switchboard and click 
on the Sign Out button. 

Visit Information 
The first tab during the sign out process is called Visit Information.  Here you will find information about 
the user and his/her department, as well as information about the student.   
 
*Hint* if you want to sign the student out using a different department or user, you can click on the 
Department dropdown box or you can click the Change… button to select a different user. 
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Advised Services 
During the sign out process, the user is allowed to select the service(s) that were provided to the 
student.  To select a service simply place a check next to the service that was given. 
 

 
 
 
When the Grouped List radio button is clicked, the list of services will be group together in a 
Parent/Child list.  This list is convenience when you need to display your services in a category fashion. 
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Visit Notes 
If a user has permission to add visit notes, then the Visit Notes tab will appear.  When this tab is 
selected, the user will have the ability to type in private and/or public notes for this student’s visit. 
 

 Private Notes: These notes can only be accessed by the user that typed them in.  When a history 
report is generated, the private notes for the student will be shown only if the user requesting the 
report was the same person that entered the notes.  If the user is not the same, then the private 
notes will not be visible. 
 

 Public Notes: These notes can be access by every user within the department that has the View 
History permission. 

 

 
 
*Hint* the ability to enter private and public notes are separate permissions that can be individually set 
for each user. 
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Advanced Save Options 
At the bottom of the Visit Information window is a check box labeled Show Advanced Save Options.  
When this option is checked, the Save Visit button will change to a dropdown list.  When this button is 
clicked, a popup menu will appear with a list of advanced saving options. 
 

 
 
Below is a description for each advanced saving option: 
 

 Save Visit… this option will allow the user to save the visit into the system.  A dialog box will appear 
requiring the user to confirm this action. 

 Save Visit: Keep Student Logged In… this option will allow the user to save the visit into the system, but 
after doing so, the student will not be logged out.  This is useful if the user wants to send the student to 
another user or to another department’s lobby. 

 Save Visit: Print this Visit Session… this option will allow the user to save the visit into the system and then 
run a report for this student’s visit session.  This is useful if the user wants to print a hardcopy of the 
student’s visit for his/her own records. 

 Save Visit: Print Student’s Visit History… this option will allow the user to save the visit into the system and 
then run an entire history report for this student.  This is useful if the user wants to replace this student’s 
existing hardcopy file with this new one. 
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Sign-Out Templates 
Who’s Next 3.0 has a feature that allows you to build sign out templates for your computer.  This way, 
instead of having to constantly click on the same services, or enter the same notes, you can click on the 
appropriate sign out template and the services and notes will be filled in for you.  This feature comes in 
handy during peak registration when you see the same types of students for the same services. 
 
When you are signing a student out, and you want to create a new sign out template, click the Apply 
Template dropdown list and click on <Customize Templates>.   
 

 
 
 
Customize Sign-Out Templates 
Who’s Next allows you to add up to 10 sign out templates per computer.  From this window simply click 
on the Add link to create a new sign out template. 
 

 

 Add/Edit: Click this link to add or edit a 
sign out template. 
 

 Copy: Click this link to copy this template.   
 

 Paste: Click this link to paste a copied 
template from your clipboard as a new 
template. 

 

 Delete: Click this link to delete the 
template. 
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Maintain Sign-Out Template 
When adding or editing a sign out template, the system will ask you for the following information: 
 

 Display Name: This is the name of the template that will be displayed during the sign out process. 
 

 Department: Click the name of the department that you want this sign out template to be 
associated with.  The list of department services will then display under the Advised Services tab. 

 

 Advised Services: Check every service(s) that you want to be associated with this sign out template. 
 

 Visit Notes: Enter any private or public notes for this template. 
 

 
 

Saving a Template 
Once you are finished making the appropriate changes, please make sure you click on the Save button at 
the bottom right of the window.  Doing so will save the template to your computer and take you back to 
the Customize Sign-Out Templates screen. 
 
*Note* please note that all sign out templates are saved to the local machine and are not associated 
with a person’s username or department.  You will have to recreate your sign out templates on other 
machines if you choose to. 
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After you save the sign out template, the template name will appear in the Apply Template dropdown 
box. 
 

 
 
*Hint* after you apply a sign out template to a visit, you can always change the visit’s information by 
unchecking and/or checking services and adding additional visit notes. 
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Toolbar Buttons 

This section explains the different toolbar buttons and their purpose.  Feel free to click on any of these 
buttons to see how they perform with your data. 
 

 
 

This button is designed to hide the Counselor Switchboard on the left 
side of the software’s interface.   Some users choose to hide this 
switchboard if they are the only ones that access their department or if 
their monitor resolution is too small. 
 

 
 

This button hides the Student Lobby window.  If a user is logged in as a 
Receptionist then they will not see this button. 
 

 
 

The Reports button takes a special permission; not everyone will see 
this button.  Clicking it will bring up the Reports Library window.  
Please see page Reports chapter for more information. 
 

 
 

This button will bring up the Program Options window that allows a 
user to modify how their Who’s Next instance works. 
 

 
 

Clicking the Unavailable button allows the user to select from a list of 
reasons why they are unavailable.  Doing this will change their folder 
to Red meaning they are not able to see students. 
 
The user can also click on Specific Reason… and can enter a reason 
why they are unavailable.  Some explains can be: “In a meeting until 
3:00pm” or “Offsite to visit with students”. 

 
 

This is a special permission that is generally is not given to users.  
Clicking this button allows the user to be logged into the system but 
their name and folder will not appear in the Counselor Switchboard.  
This allows the user to see how is logged in at the moment but the 
other users cannot see if he/she is. 
 

 
 

Clicking this button will bring up the Messenger window.  Please see 
page Instant Messenger chapter for more information. 

 
 

Clicking this button allows the user to read the Who’s Next PDF help 
documents. 
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Student Lobby / My In-box Toolbar  

This section explains the different toolbar buttons found on the Student Lobby or My In-box toolbars. 
 

 
 

Clicking the Sign In button will allow the user to sign in a 
student into either the Student Lobby or the user’s In-box.  
Please see the Signing Students In section for more 
information. 
 

 
 

Clicking this button will start the sign out process for the 
selected student. 
 

 
 

This button allows the user to remove the selected student 
from the Student Lobby or My In-box.  This can be used in 
the case that a user signs in an incorrect student or the 
student leaves without being seen. 
 

 
 

This button will bring up the Student Search tool.  Please see 
page Student Search Tool section in the Student 
Maintenance chapter for more information. 
 

 
 

This dropdown box allows the user to select which Student 
Lobby he/she wants to see.   

 
 

The Visit Notes button allows a user to run reports to see a 
student’s visit history or last visit.   
 
*Hint* instead of using this toolbar button we recommend 
right-clicking a student and clicking the View Student’s Visit 
History… menu option. 
 

 
 

Clicking this button will refresh the Counselor Switchboard, 
the Student Lobby and the user’s My In-box window. 
 

 
 

This button will bring up the Column Chooser window.   
 

 
 

This button will bring up the Sort Columns window.   
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Student Popup Menu 

 

Right-clicking on a student either in the Student Lobby or My 
In-box window will show a popup menu.  Depending on the 
user’s current permissions, some of these options may be 
hidden or disabled. 
 

 

 View Appointment Information: This option will bring up the student’s appointment info, if he/she 
selected one while signing in. 
 

 Sign Student In: This option allows a user to sign a student into the Student Lobby or My In-box. 
 

 Sign Student Out: This option allows a user to sign out the selected student. 
 

 Sign Multiple Students Out: This option will bring up a window that allows a user to sign out multiple 
students.   

 

 View Student’s Visit History: This option will run a report that shows the history for the selected 
student. 

 

 View Student’s Last Visit: This option will show the last time the student came into the selected 
department. 

 

 Copy Student’s ID to Clipboard: This option will copy the selected student’s ID to the computer’s 
clipboard.  This can then be used to paste into other applications if necessary. 

 

 Add New Student: This option will allow the user to add a new student into the system. 
 

 Edit Student’s Information: This option will allow the user to edit the selected student’s 
demographic information like the student’s name, address or contact phone numbers. 

 

 Edit Student’s Sign In Information: This option allows the user to edit the information the student 
used to sign in like the counselor they want to speak with and the service that want to receive. 
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 Refresh: This option will refresh all windows with the application. 
 

 Column Chooser: This option will bring up the Column Chooser window.   
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Department Maintenance 

 

Who’s Next allows a system administrator to add as many 
departments as necessary into necessary.  Administrators 
can also edit, delete or recover departments as well.   
 
To access the Department Maintenance window, please 
go to Edit > Department Maintenance… 
 

 

List of All Departments 
This window shows every active department in the system.  Click the appropriate button on the right 
side to add, edit, delete or recover a department. 
 
*Hint* deleting a department does not delete any data within the system.  The department is “flagged” 
as deleted but the records stay in the database. 
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Department Information 
When adding a new department, please enter the department’s name and Student Sign-In Station 
password.  Although users never get to see the password, we recommend the Password Type be set to 
Advanced.   
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Student Maintenance 

If a user wants to make changes to a student’s profile, and he/she is not currently logged in, the user can 
go to Edit > Student Maintenance… Please note that the user will need the right permissions to access 
this feature. 
 

Student Search Tool 
The first window that pops up is the Student Search Tool.  This tool allows you to search for the student 
using any part of the student’s last name, first name or Student ID.   
 

 
 
*Hint* clicking any of the letter buttons will retrieve all students whose last name starts with that letter. 
 
Once you find the appropriate student put a check mark next to his/her name and click Add Item.  This 
will add the student ID into the previous screen that called this window. 
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List All Students 
After you found the student you were looking for, and added the student to this window, then you can 
click any of the buttons on the right side to add, edit, delete or recover students.  Clicking Search… will 
bring up the Student Search Tool again.   
 

 
 
*Hint* deleting a student does not delete any data within the system.  The student is “flagged” as 
deleted but his/her records stay in the database. 
 

Edit Student’s Information 
This screen will prompt you to add/edit the student’s information.  The only information that is required 
for the student is the first name, last name and student ID number. 
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Academic Information 
The Academic Information tab allows a user to enter the student’s Grade Classification, Degree Type or 
Subject Major.  You can select an existing option from the appropriate dropdown lists or enter a new 
one. 
 

 
 

Department Information 
The Department Information tab shows a dropdown list of all counselors that have access to this 
department.  By selecting a user from this list, then when the student signs in, and the DefaultUser 
column is being shown, the default user’s name will appear. 
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Picture 
The Picture tab allows the user to import a picture of the student into the database.  The user can then 
use the Column Chooser to show the ClientPicture column. 
 

 
 
*Hint* before you can show the student’s picture in the Student Lobby or My In-box, the user has to go 
to the Program Options window and turn this feature on.   
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Merge Students 
The List All Students window has a Merge button that allows you to merge two student records 
together.  This is sometimes used when a student builds an account using one ID number and then a 
second one using their newly created student id number.  You can use this window to merge both 
records together. 
 

 
 

Merge Student ID Numbers 
Enter the first student ID number in the 1st Student ID text box and then enter the second student ID in 
the 2nd Student ID text box.  When you click the Merge Now button the system will move all of the 
records associated with the first student ID into the second student ID and then will remove the first 
student ID. 
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Swap Students 
The List All Students window also has a Swap button that allows you to swap student information based 
on two different ID numbers. 
 

 
 

Swap Student ID Numbers 
Enter the first student ID number in the 1st Student ID text box and then enter the second student ID in 
the 2nd Student ID text box.  When you click the Swap Now button the system swap all visit records 
between both students. 
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User Maintenance 

To add, edit, delete or recover users from the Who’s Next system please go to Edit > User 
Maintenance…  Please note that you will need special permissions to access this feature. 
 

Showing All Department Users 
This window shows every user that has access to the current department.  If you want to see a listing of 
users that have access to all your departments, click the All Authorized Departments radio button. 
 

 
 

Available Licenses 
When this window opens, the first thing the software does is it connects to 
our licensing server to see how many licenses your school has purchased.   
That information is placed in the Licenses Purchased field. 

 

 
It then queries the system to see how many licenses are currently being used.  
That number is placed in the Total Licenses Used field.   
  

If the number of Total Licenses Used is less than the Licenses Purchased, then the Add… button will be 
enabled.   

Adding a New User 
To add a new user into the system, click on the Add… button at the top right of the window.   
 
*Note* please note that your school’s account may have a password associated with its licenses.  If it 
does then the system will prompt you to enter the password before you can add a new user. 
 
*Hint* in order to be able to add a new user into the system, the current users must first be granted the 
Can Add New Users permission. 
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Editing an Existing User 
To edit an existing user, click on the Edit… button at the top right of the window.  This will bring up the 
Edit User window. 
 
*Hint* in order to be able to edit an existing user, the current users must first be granted the Can Edit 
Users permission. 
 

Properties Tab 
The Properties tab prompts for some of the basic information about the user. 
 

 
 User Name: This is the unique identifier for the user.  This name cannot be used more than once. 

 

 Password: Our software does not require a certain number of characters or letters, and it does not 
require the user to change their password after a certain number of days. 

 

 Title: This can be used to let the students know what type of counselor this user is. 
 

 Password Type: We recommend always select Advanced in this dropdown box. 
 

 Is Enabled: This field determines if the user can log into the system.  If it is unchecked then the user 
will not be able to log in even if they entered the correct username and password. 

 

 Require Password Change at Next Login: This check box determines if the users should change 
his/her password the next time they log in. 

 

 Role Types: These two fields determine if the user can log in as a Reception, a General User or both.  
Remember that a Receptionist only sees the Student Lobby whereas a General User (i.e. counselor) 
has access to the My In-box window. 
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Permissions Tab 
The Permissions tab controls what the user can and cannot do for each department.  This is a very 
complex window that takes some getting used to. 
 

 
 
Right under the Permissions tab is a check box labeled Is a System 
Administrator.  Checking this box will disable the rest of the permissions 
and will give the user admin access to the entire system. 

 

 
*Note* our support office gets a lot of phone calls saying that they need to have system administrator 
access, when in fact they really need full access to their department.  Please remember that system 
administrator access means they can perform additional functionality like adding/deleting departments 
and changing user password.  Please be careful who this access is given to. 
 

Department Access 
In order for a user to have access to a department, this department must be checked.   
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However, when a department is checked, all of the permissions under that department are also 
checked.  Please be careful when giving a user access to a department; you don’t want to give him/her 
more access than they need. 
 

 
 
In order to correct this issue, Who’s Next has a feature so that when you right-click on a department a 
popup menu will appear.  At the top of this menu is an option called Set Default Values.  When this 
option is clicked, the system will check the department but will only check the permissions that have 
been flagged as IsDefault.  This means that the user will only be given the minimum for this department 
and he/she will not be able to perform more advanced functions. 
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Access to Visit Notes 
The Access to Visit Notes tab allows a user to run a report on a student’s past visit history for 
departments he/she does not have direct access to.   
 
For example, let’s say that a user only has access to Financial Aid, but she needs to be able to run visit 
reports for student in Advising.  Although she may only have login access to Financial Aid, with this 
feature she will be able to run visit history reports for both Financial Aid and Advising. 
 

 
 

Sign-In Picture 
The Sign-In Picture tab allows a user to add their profile picture.  This picture can then be displayed at 
the Student Sign-In Station when students sign themselves in. 
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Deleting an Existing User 
To delete an existing user, click on the Delete… button and then click Yes to confirm it.  Please 
remember that the user has only been flagged as deleted and their past visit information stays in the 
system.  When a user is deleted, the system will automatically free up that one license so that you can 
use it for another user.   
 
*Hint* If you are currently out of licenses and you want to add a new user, please consider deleting an 
user account that you no longer need.  Doing so will keep all of his/her past records but will flag the 
account as deleted.  The software will free up a new license that you can then use by clicking the Add… 
button.   
 
*Warning* We DO NOT recommend changing the username of the old username to the new username.  
Doing so will change all of the past visit records for the user.  Undoing this procedure cannot be 
guaranteed. 
 

Recovering a Deleted User 
To recover a deleted user simply click on the Recover… button.  The next window will allow you to select 
the user and click the Recover button. 
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Service Maintenance 

Every department that uses Who’s Next has the ability to add an unlimited number of services.  These 
services can range anywhere from Add/Drop Classes to Referrals and Personal Counseling.  Anything 
that a department offers to their students can be built as a service. 
 
To access the Service Maintenance window simply go to Edit > Service Maintenance…  *Note* Please 
note that you will need special permissions to access this feature. 
 

List of All Services 
This window will show all of the services for the department you are currently logged into.  They are first 
sorted by the Service Group and then by Service Name. 
 

 
 
*Hint* please remember that this list only shows the services for the department you are logged into.  If 
you want to change departments quickly simply click on the File menu and click Change Departments… 
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Editing an Existing Service 
The screenshot below shows what it looks like when a user is editing an existing service. 
 

 
 

 Service Group: This field is used when displaying the Group List services while signing a student out.  
This helps keep services in a grouped (or category) list for users to find quickly.  To add a new service 
group, simply click on the <New Group> item.  A window will display prompting for the service 
group name. 
 
Once the Service Group name is saved in the database, that name will appear in the dropdown box 
next time. 
 

 Service Name: This is the name of the service that will be displayed throughout the software. 
 

 Is Enabled: This field tells the software if the service should be displayed. 
 

 Show Service During: This field tells the software when the service should be displayed.  The options 
are: 

o Sign-In Only: This option means that only the students will see this service when they are 
signing themselves in.  The user will also see this service when they are signing a student in.  
Please see the Advanced Sign-In Screen section in the Signing Students In chapter for more 
information. 
 
This option can be very useful because some departments only want their students to see a 
short list of services when they are signing themselves in.  Students don’t necessarily have 
to see the department’s complete list of services. 
 

o Sign-Out Only: This option means only counselors will see the service when they are signing 
students out. 

 



47 | P a g e  
 

o Sign-In & Sign-Out: This option allows the service to be shown during the sign in and sign out 
process. 

Log Off to see New Service List 
When a user makes a change to his/her department’s services, all of users that are currently logged into 
Who’s Next will not see these changes until the log off and re-log back into the software.  Once they do 
that, the new list of services will be downloaded to their computers automatically. 
 
The same goes for the Student Sign-In Station component.  Any workstation running this component will 
need to have the software re-launched in order to see the new list of services. 
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Reports 

 

When a user has access to the Reports Library, he/she will see this Reports button on the 
main toolbar.  Clicking this button will bring up the Reports Library window. 

 
The Reports Library is made up for 50+ reports and is separated in 5 different categories.  These 
categories are Visit Reports, Service Reports, Calendar Reports, Customized Reports and All Reports. 
 

 
 

 Visit Reports: These reports will show the number of student visits that were captured in a given 
time frame.  These reports are designed to show summarized data by departments, counselor or 
students, and also show detailed information as well. 
 

 Service Reports: These reports show the number of services that were given out during a particular 
time frame.  Please remember that a student visit can have one (or more) services given.  This 
means that when service reports are ran, these numbers are almost always higher than visit report 
numbers. 

 

 Calendar Reports: These reports show information about a department’s appointment calendar. 
 

 Customized Reports: These are specially designed reports that are only to be used by a particular 
institution.  When a new school wants a particular report, and this report is not going to be used by 
any other school, we will build the report and add it to your school’s Customized Reports list.  This 
way only your school will be able to view this report. 

 

 All Reports: This list will show all of the reports in a single list. 
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List of Reports 
When a user clicks on one of the categories at the top of the window, the list of Available Reports will 
refresh to only show the reports in that category.  
 

 
 

Report Filters 
Selecting a report will automatically enable/disable the report filters on the right side of the window. 
 

 
 
*Hint*: by default the Departments dropdown list says All 
Departments.  When a user selects a specific department 
from this list, the software will refresh the data found in the 
Service Groups, Service Name, and User Name lists based on 
the selected department.  This will then allow the user to 
filter the reports by selecting additional criteria. 
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Report Viewer 
When a report is executed, and the system returns one or more records, the report will be displayed in 
the Report Viewer window.  This powerful window allows you to perform certain duties like printing or 
saving the report, exporting the raw data or even adding charts. 
 

 
 

Printing a Report 

 
To print a report, simply click on the Print button at the top-left of the window.  Doing so 
will bring up the Print dialog box. 
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Saving a Report 

 A user can save a report to his/her computer by clicking the Save Report button.  The 
software will bring up the PDF Export Options dialog box before asking the user where 
to save the file. 
 

 
 

Emailing a Report 

 A user can email a report by clicking the E-Mail Report button.  The software will 
prompt the user to save the report to his/her computer and then will open up the 
default email program (i.e. Microsoft Outlook) with the report already attached to it. 

 

Exporting a Report’s Raw Data 

 
Who’s Next has a feature that allows a user to export the report’s raw data to 
Microsoft Access® or Microsoft Excel®.  Doing so allows the user to modify the 
data if necessary. 

 

Embedding Charts 
Some of the reports within Who’s Next are designed to have 
charts embedded in them.  Clicking either the Bar, Pie or Line 
buttons on the toolbar will embed a  colorful chart at the bottom 
of the report. 
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Program Options 

 

The Program Options window allows users to configure how their version of 
Who’s Next works.  These settings are programmed to only change their local 
computer; other computers will not be affected. 
 
You can also get to the Program Options window by going to Tools > Program 
Options… 

 
The left side of the window shows the different Program Option categories.  Selecting any one of these 
items will display different options on the right side of the window. 
 

XML File Location 
When the Who’s Next application closes, the software attempts to write the program options to specific 
XML files on your computer.  The XML files are found in this directory: 
 

C:\ProgramData\Blue Eon Solutions\_Settings\Whos Next\Options\Main 
 

 
 
 

Read/Write Permissions 
During the use of Who’s Next, the software will try to read and write data to XML files located in the 
directory above.  In order to do this, your Microsoft Windows account must have read/write permissions 
to this directory.  Otherwise the next time you launch Who’s Next the software will revert back to its 
default program options settings. 
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Alerts 

 
 

 Alert me when students are logged into My In-box: 
This option will alert the user that a student has been assigned to him/her by displaying a popup 
message.   
 

 Play sound when students are logged into the Student Lobby: 
This option will sound a chime when a student shows up in the lobby. 

 Show balloon tips in the computer’s system tray when students are logged into the Student 

Lobby: 

This option will display a small popup message at the bottom-right of the user’s computer notifying 
him/her that a student in now in the lobby. 

 

 Show balloon tips in the computer’s system tray when a student selects my name while signing 
into the Student Lobby: 
When a student signs him/herself in using the Student Sign-In Station, and that student selects a 
specific user to speak with, that user will get an alert message on their computer. 

 

 Show balloon tips in the computer’s system tray when one of my appointments logs into the 
Student Lobby: 
When a student signs him/herself in into an existing appointment using the Student Sign-In Station, 
that user will get an alert message on their computer. 

 

 Balloon tips auto close (in seconds): 
This option controls how long the popup message stays up on their computer. 
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Appointment Calendar 

 
 

 Check for double bookings when creating appointments: 
 Allow double bookings appointments. 
 Do not allow double booking appointments. 

 
When this option is turned on, and a user tries to create an appointment, the system will query the 
system to make sure the user does not already have an appointment at that time.  If an 
appointment is found, then the system will add the appointment depending on which of its sub-
options is selected.  
 

 Number of days your calendar should go back to retrieve appointments: 
This option tells the software how far back to look for and load appointments. 
 

 Number of days your calendar should go forward to retrieve appointments: 
This option tells the software how far forward to look for and load appointments. 
 

 Visible start time: 
This option sets the default visible area that the calendar will show.  A previous version would start 
the day at 12:00 am.  Now with this option, it will show the start time of 6:00 am, or whatever start 
time you set. 
 

 Visible end time: 
This option mirrors the Visible start time option, but it will show the default end time for the 
calendar. 
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 Change appointment end time after selecting service: 
If you have the Appointment Scheduler component enabled, then every department has the ability 
to set a minute interval with every service.  When saving an appointment, if you have this option 
turned on, then the software will automatically set the end time based on the service minute 
interval. 

 

 Show service types in the ‘Subject’ list: 
When saving a new appointment, Who’s Next can automatically load certain services in the Subject 
drop down list.  This prevents the user from having to type them in.  Check the appropriate service 
type to set which services to show. 
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Auto-Login 

 
 

 Turn the ‘Auto-Login’ feature on: 
This option enables or disables the Auto-Login feature.  If it is turned on, then the software will use 
this information next time to automatically log the user in. 
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Database Refresh Interval 

 
 
This option controls how often the software will automatically refresh.  The fastest it can go is ten (10) 
seconds and the slowest is sixty (60) seconds.   
 
There may be times when a user does not want their software to automatically refresh.  If this is the 
case then he/she can uncheck the Enable Refresh Interval option.  When this option is unchecked then 
the user will have to manually refresh their software. 
 
*Important* although some users may want to refresh every 10 seconds, please note that this will take 
more processing power on the server and more network throughput.  We recommend keeping this 
option to 60 seconds. 
 

 Delay calendar refresh: 
Instead of having the calendar refresh every time the software refreshes, this option allows the 
workstation to delay the calendar refresh.  This option is recommended for offices that have a lot of 
appointments saved in the system.   
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General Options 

 
 

 Enable Switchboard Sorting: 
This option will automatically sort the list of students based on the pre-selected sorting column. 
 

 Enable Switchboard Numbering: 
This option will place a numerical value of where the student is in line in front of the first column in 
either the Student Lobby or the My In-box windows. 
 

 Enable TRiO Identifier in Switchboard: 
This option will display a different icon next to the student if he/she is identified as a TRiO student.  
*Note* this option requires the TRiO option be turned on within the database.  
 

 Update username when dragging students to a department: 
When a student is dragged to another department, by default the software will update the 
“Requested User” field by adding the name of the person that did the drag-and-drop.  For example, 
the data would be updated to “Sent by: John Smith”. 
 
Unchecking this option will prevent the software from updating the information in this field.  This is 
helpful when you want to retain the name of the person the student wants to speak with. 

 

 Show student alias while signed in: 
When a student signs in and is shown in the Student Lobby (or in your Inbox), the software will show 
the student’s alias after their name (if they have an Alias assigned to them). 
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 Show students in user’s inbox on double click: 
When you double click on a user’s folder in the Switchboard, by default it will open a new Instant 
Messenger window.  However, when this option is turned on, it will show the students that are in 
the user’s inbox instead. 
 

 Show default user per each department: 
A previous version of our software allowed each department to assigned default users to each 
student.  Just recently we’ve had schools request this feature to be modified so that the default user 
would show up across all departments.  This option helps control if the software will show the 
default user per department or for all departments. 
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Instant Messenger 

 
 

 Allow for incoming messages: 
This option controls whether the user’s computer will allow for incoming instant messages from 
other computers. 
 

 Allow for outgoing messages: 
This option controls whether their instance of Who’s Next can send outgoing messages to other 
computers. 
 

 Mute sounds: 
This option can mute any sounds played by the instant messenger. 
 

 Use Port: 
This option controls which port the software will communicate with other computers.  In order for 
one computer to send instant messages to another computer, both computers must be using the 
same port number. 
 
*Note* if any of these options are changed, they will not take into effect until Who’s Next is closed 
and restarted on this computer. 
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Program Terminology 
The Program Terminology window can be used to change the terms used for students and/or 
counselors. 

 
 

 Student Input Mask 
This option controls how many numbers and/or characters can be keyed in when entering a student 
ID number.  For numbers please enter a pound sign (#) for every number in the student ID number. 
 
For example: If a student id number is 9 digits long (i.e. 123456789) then enter #########. 
 

 Pad Character 
This option will pad a character in front of any student id number if the correct amount of 
characters is not entered. 
 
For example: If a student ID number is 9 digits long, and they only enter 5 numbers (i.e. 12345), then 
the software will pad 4 zeroes in front of it, resulting in 000012345. 

 
Student Terminology 

 Singular: 
This tells the software what the singular term for student is. 
 

 Plural: 
This tells the software what the plural term for student is. 
 

 Possessive: 
This tells the software what the possessive term for student is. 
 

 ID Name: 
This tells the software what to call the student ID number. 
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Counselor Terminology 

 Singular: 
This tells the software what the singular term for counselor is. 
 

 Plural: 
This tells the software what the plural term for counselor is. 
 

 Possessive: 
This tells the software what the possessive term for counselor is. 
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Sign-In Options 

 
 

 Can randomly generate student id: 
When this option is turned on, and the Student Input Mask 
also has a value, then the user can elect to randomly 
generate a student id if he/she does not have one. 

 
 

 Use advanced sign-in screen by default: 
When the student clicks the Sign In button to sign 
a student in, if this option is turned on, then the 
Advanced Sign-In Screen will come up instead of 
the Basic Sign-In Screen. 
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 Enable pager ID (advanced sign-in): 
When the user signs in a student using the 
Advanced Sign-In screen, this option will control 
whether or not the Pager ID field is displayed. 

 
 
 

 Show Student Sign-In Questionnaire: 

This option tells the software is the Student Sign-In Questionnaire should come up while signing in a 
student. 

 Interval (In Days):  
This value tells the software how far back the software should go to see when the student 
last filled out the Student Sign-In Questionnaire.  If the number of days exceeds this value 
then the software will prompt the student to fill it out again.   
 
If this option is set to zero (0) then the software will prompt the student to fill out the 
Student Sign-In Questionnaire every time he/she signs in. 
 

 Copy student id to clipboard during sign-in: 
This option will automatically copy the student’s ID to the computer clipboard when signing a 
student in. 
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Sign-Out Options 

 
 

 List services as: 
This option tells Who’s Next to display the list of services during sign out as a list view (alphabetical 
order) or tree view (grouped list). 
 

 Defaulted notes: 
While signing a student out, when a user clicks on the Visit Notes tab, this option will tell the 
software to place the cursor in the private notes section or the public notes section. 
 

 Allow application to determine if this is the student’s 1st visit: 
Please disregard; this option is no longer in use. 
 

 Confirm every visit being saved: 
When a user clicks the Save button to save his/her student’s visit, the software will show a 
confirmation screen, prompting the user to confirm this save.  Unchecking this option will disable 
this confirmation screen. 
 

 Show advanced save options by default: 
This option tells the software to show the Advanced Save Options when signing students out. 
 

 Verify accuracy of sign-out time when saving visit: 
There have been times when users leave students in their My In-box windows for long periods of 
times (sometimes overnight) 



66 | P a g e  
 

 
As a workaround, this option will check to see how long the student’s visit occurred.  If the number 
of minutes is greater than the value in the Date difference field, then the software will to take the 
student’s sign in time and add the value found in the Default date interval field (in minutes). 
 
For example: say a student signed in on 8/1/2013 at 9:00am but was not signed out until 8/3/2013 
at 11:30am.  Because the sign out time was greater than 120 minutes (the Date difference value), 
then the sign out time would look like this: 
 

 Date difference: 120 minutes 
 Default date interval: 30 minutes 

 
 Student’s sign-in time: 8/1/2013 9:00am 
 Student’s sign-out time: 8/1/2013 9:30 am 

 
 

 Load student’s last visit if it falls within the current day: 
Please disregard; this option was custom built for another school. 
 

 Load student’s last visit if it falls within the current month: 
Please disregard; this option was custom built for another school. 
 

 Show your department’s offsite locations: 
This option will show the Offsite Location dropdown list on the sign out screen. 
 

 Auto load sign-in services during sign-out: 
If a student selected one or more services during the sign in process, when this option is checked, 
those services would be automatically checked during on the sign out screen. 
 

 Save courses during sign-out: 
If a student selected one or more courses during the system in process, when this option is checked, 
those courses would be saved with their visit. 
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Student Pictures 

 
 

 Can show student pictures: 
This option tells Who’s Next if it should display student pictures in the Student Lobby or My In-box 
windows. 
 

 Read images from database: 
This option allows Who’s Next to retrieve the student pictures from the Who’s Next database.   
 
*Hint* if your current master data system has the student pictures, then we can show you how to 
export this data from your master database to the Who’s Next database. 
 

 Rad images from folder: 
This option will read the student pictures files from a specific file directory or share from your 
network.  Most of the schools we work with read their student pictures this way. 
 

 Auto resize: 
This option will automatically resize the picture to a certain height and width. 
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Texting Options 

 
 

 Move students to my inbox after summoned: 
When this option is checked, and when you summon the student via text message, the software will 
automatically move the student from the Student Lobby to your Inbox.  This is a great way to 
manage which students you’ve already summoned. 
 

 Can summon students without cell phone numbers: 
Although the summon feature is designed to send a text message to students that have opted in to 
receive text messages, Who’s Next can still flag the student as “summoned” even though it does not 
text them.  It will flag the date/time they were summoned in the database. 
 
*IMPORTANT* please note that you these Texting Options will only appear if your school has opted 
in to use the Text Messaging service.   
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Appointment Calendar 

The Appointment Calendar component allows users to manage their appointments within Who’s Next 
rather than other 3rd party applications like Microsoft® Outlook®.  This component is automatically 
enabled but it can be disabled for the entire institution if necessary. 

Viewing your Calendar 
Click on the Appointment Calendar button at the bottom of the Counselor Switchboard window. 
 

 
 
 
The main window within Who’s Next will now show the Calendar window.  The calendar will 
automatically load your current appointments for the department you are logged into. 
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Program Options 
The current version of our software only shows appointments that fall within a specified time frame.  By 
default the software will go back 14 days and forward 14 days.  This means that if you add an 
appointment that is 15 days or more in the future, our Appointment Calendar will not show it the next 
time you log in. 
 
To modify this date limit please go to Tools > Program Options… and click on the Appointment Calendar 
option.  On the right side of the window you can modify the number of days the calendar will go back 
and forward to retrieve your appointments. 
 

 
 
 

Date Range Picker 

 

The left side of the Appointment Calendar has a window that allows you 
to select any number of dates.  Dragging across any date range will 
automatically refresh the calendar to show the appointments for the 
dates you selected. 
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Change Time Scale 

 

Right-clicking on the calendar’s time scale allows you to change 
the duration of the calendar.  This enables you to see more or less 
details in your calendar. 
 
The Show Minutes toggle option tells the calendar to show or 
hide the minutes within the time scale.   

 
 

Creating a New Appointment 

 
To create a new appointment simply double-click anywhere within the calendar or click the 
New button on the calendar’s toolbar.  Doing this will bring up the new appointment 
window. 

 

 
 

 Subject: 
This required field allows you to enter the subject for this appointment.  The software will also load 
any advisement services (Edit > Services Maintenance…) that have been designed with the 
Appointment Calendar service type.   
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 Location: 
This optional field allows you to enter where this appointment will take place. 
 

 Start Time: 
This required field allows you to designate the time this appointment will begin. 
 

 End Time: 
This required field allows you to designate when this appointment will end.  The end time must 
come after the appointment’s start time. 
 

 Department: 
This drop-down box allows you to associate the appointment to a specific department. 
 

 Appt Type: 
This drop-down box allows you to associate an appointment type (category) to this appointment.  
For more information about maintaining appointment types please see the XYZ section. 
 

 Description: 
This text box allows you to add additional information regarding the appointment.  Our software 
allows you to enter up to 500 characters into this field. 
 

 Is All Day: 
This check box tells the calendar if the appointment is to last 
all day.  If so then the appointment will appear at the top of 
the calendar window rather than inside it. 

 
 

 Is Private: 
When this box is checked, the appointment will show up in your calendar only.  No other user will be 
able to see this appointment. 
 

 Cancelled: 
This box tells the system that the student decided to cancel the appointment.  This will then allow 
you to run reports to see how many appointments have been cancelled. 
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 No Show: 
Mimicking the same functionality as the Cancelled box, this box tells the system that the student 
was a no show.  You can then run a report to see how many students were no shows. 
 

 Is Open for Appointments: 
This check box tells the system to display this appointment in the Who’s Next – Online 
Appointment Scheduler web component.  For more information about this add-on feature please 
call 1.866.317.0256 or visit http://www.BlueEonSolutions.com. 
 

 Counselor: 
This drop-down box allows you to assign the appointment to a specific user’s calendar. 
 

 Max. Attendees: 
This field allows you to see which students have signed up for this appointment.  This feature is tied 
directly to the Who’s Next – Online Appointment Scheduler component. 
 

 Student ID 
The field allows you to assign one (1) student to this appointment.  When you do this, the student’s 
name and ID number will appear in the calendar. 

 
 

Export Appointment 
You can export an appointment to a single iCalendar (.ics) file.  Right-click on any appointment and 
select Export appointment as…  The next window will allow you to save the iCalendar file to your local 
computer. 
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Reoccurring Appointments 
When creating a new appointment, Who’s Next gives you the ability to set it as reoccurring.  To do this, 
simply click on the Recurrence… button at the bottom-right of the window. 
 

 
 
 
The Appointment Recurrence window will appear, allowing you to select the recurrence pattern and the 
recurrence end date. 

 

 
 
 
  



75 | P a g e  
 

Shared Calendars 

 
Who’s Next has the ability to show multiple calendars at the same time.  To do 
this, simply click on the Shared Calendars button on the calendar’s toolbar. 

 
The Shared Calendars window will show you a list of all the users that have access to your department.  
You can place a check next to every user whose calendar you want to view.  Clicking the Check All and 
Uncheck All button will check/uncheck all of the users in this list, respectively. 
 

 
 
 
When you select more than one user from the Shared Calendars list, and you click the Select button, 
your calendar will refresh to show all of the calendars that you selected. 
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Appointment Types 

 

If your user profile has the ability to add, edit or delete appointment 
types, then this button will appear on your calendar’s toolbar.  
Clicking this button will open up the List of All Appointment Types 
window. 
 
To give a user access to this component, go to Edit > User 
Maintenance… Under the Permissions tab expand your department, 
expand Appointment Calendar and check the appropriate 
permissions. 
 

 

 

List of All Appointment Types 
This window will show all of the appointment types for the department you are currently logged into.   
 

 
  



77 | P a g e  
 

Editing an Existing Appointment Type 
The screenshot below shows what it looks like when a user is editing an existing appointment type. 

 

 

 Appointment Type Name: This field is the name that will be displayed when adding or editing an 
appointment. 
 

 Display Color: This field designates the color for the appointment type. 
 

 Is Enabled: This field tells the software if the appointment type should be displayed. 

 

Sync Your Calendar with Microsoft® Outlook® 

 

Who’s Next allows users to manually sync their calendars with 
Microsoft® Outlook®.  To do this, click on the Options toolbar button 
and select Sync Calendar. 
 
 

Our appointment calendar performs a bi-directional import, meaning that it will import any 
appointments from your local Outlook® calendar into your Who’s Next calendar.  Our software will also 
export your appointments from Who’s Next into your Outlook® calendar. 
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Instant Messenger 

Who’s Next has a built in Instant Messenger that allows users to chat with each other.  In order for a 
message to be sent to a user, that person must first be logged into the software.   
 
To send an instant message, simply double-click on the user’s name in the Counselor Switchboard or 
right-click on the user and click the Send {person’s name} an Instant Message… 
 

 
 
 

Chat Window 
This text box at the bottom of the chat window allows you to enter your chat message.  Click the Send 
Message button to send the message to the person you are chatting with. 
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Buzz/Shake 
There may be times when the person you are chatting with does not know you sent them an instant 
message.  Clicking the Buzz/Shake button will try to get their attention by playing a sound on their 
computer and shaking their chat window. 
 

 
 

Chat Templates 
The Templates button shows a list of pre-configured chat messages.  Clicking any one of these items will 
send that message to the person you are chatting with.  Clicking the Customize Templates… item will 
allow you to change your list of templates. 
 

 
 
*Note* when customizing your templates, these changes will get saved to your local computer.  These 
templates are not tied to a user’s profile or to a specific department. 
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Send Group Message 

 

Who’s Next has a feature that allows a user to send a message to multiple people.  
Clicking the Messenger button on the main toolbar will bring up a list of everyone 
logged in.  From this window, place a check next to every user you want to send this 
message to and then click the Start Chat… button. 

 

 
 
 
This will then bring up the Sending Group Message window. 
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Instant Messages Fail 
There may be times when a user cannot chat without another user.  The screenshot below will appear if 
the message cannot be sent. 
 

 
 
For illustration purposes, let’s say that a user named David (computer #1) is trying to send a message to 
Shannon (computer #2).  When trying to send a message to Shannon, David gets this error message on 
his computer.  The cause of this error is usually one of the following: 
 

 Not Running Properly: Shannon’s instant messenger may not have started properly.  Please close 
out of Who’s Next and try running it again. 
 

 Windows Firewall: Shannon’s computer has the Microsoft Windows firewall turned on, which 
usually stops incoming messages.  To resolve this problem, either turn off the Windows firewall or 
configure it so that it allows the Who’s Next application to run. 
 

 Different Ports: the port Shannon is using may be different than the port David is using.  Please go 
to Program Options and click on Instant Messenger to see what port both computers are using. 
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Text Messaging Service 

Who’s Next has a fully integrated Text Messaging Service that allows students to receive text messages 
via their cell phone.  Our software sends out your text messages using our corporate web server.  This 
means that your IT does not have to purchase or manage any additional hardware; our servers take care 
of it all. 
 
Department Configuration 
Each department that wants to send text messages has to be individually configured to use it.  Our 
customer support team will assist you in setting up these configurations. 
 
Enter a Student’s Cell Phone Number during Sign-In 
Once your department has been configured to send text messages, and when you go to sign in a 
student, you will be prompted to enter the student’s cell phone number.  The Counselor/Receptionist 
component of Who’s Next is designed to bring up the student’s last cell phone number for your 
department.   
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Show Student’s Cell Phone in the Student Switchboard 
The Student Switchboard has the ability to show you the last 4 digits of the student’s cell phone number.  
This way you can tell if the student opted in/out during the sign-in process. 
 
Click the Column Chooser button the Student Lobby toolbar. 
 

 
 
 
Find an available column and select CellPhone.  Click the OK button when you are done. 
 

 
 
 
You will now see a column labeled Cell Phone that shows the student’s cell phone information. 
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Send a Text Message to a Student 
Once a student is signed in, and they opted-in by entering their cell phone, you can send them a 
customized text message by clicking the Send Text button. 
 

 
 
 
The New Text Message window allows you to enter any message up to 150 characters.  Click the Send 
button when you are finished. 
 
While Who’s Next is running, the software will remember the last text message you sent.  This prevents 
you from having to key in the same message every time. 
 

 
 
*Note* when entering a text message, please note that you cannot use a single apostrophe or double 
quotes. 
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Send a Text Message Batch to Students 
Who’s Next also gives you the ability to send a text message to multiple students.  By clicking the down 
arrow next to the Send Text button, you will see a Send Batch of Messages… option. 
 

 
 
 
The Batch of Text Messages window will display all of the students waiting in current department’s 
lobby.  This list will only show the students that opt-in by supplying their cell phone number. 
 
After you check/uncheck the students that will receive this text message, go ahead and enter the 
message in the text box at the bottom of the window.  Click the Send Message… button when you are 
done. 
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Summon Students via Text Message 
Who’s Next has a summon feature that allows you to notify students when they are ready to be seen.  In 
order for you to use the summon feature, you must first configure your department by entering the 
predefined summon message.  Please see page XYZ for more information. 
 
Once your department has entered the predefined summon message, you will see a Summon button on 
your toolbar instead of the Send Text button. 
 

 
 
 
The software will prompt you to ensure you want to summon the specified student.  Clicking the Yes 
button will tell the software to send the predefined summon message to the student. 
 

 
 
 
When summoning students, Who’s Next has a couple of program options that you can turn on or off.  
You can configured these options by going to Tools > Program Options… and then clicking on Texting 
Options. 
 

 
 

 Move students to my inbox after summoned: After you summon a student, Who’s Next has the 
ability to move the student to your inbox automatically.  We built this feature for a school so they 
could keep track of which students have been summoned and which ones have not. 
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 Can summon students without cell phone numbers: Even if a student opted-out of the text 
messaging feature, this feature will still move a student to your inbox after they have been 
summoned.  They will not receive the summon text message, but they will still be flagged as being 
summoned. 

 

User Permissions 
In order for users to send text messages, they must first be granted the appropriate rights for their 
department.  You can find these permissions by going to Edit > User Maintenance…  Edit a user’s profile, 
click the Permissions tab and then expand Texting Component. 
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Department Text Templates 
When sending a customized text message, Who’s Next has a template feature that allows to you load 
predefined text messages for your department.   
 
Click on the Template dropdown list and select <Customize Templates>. 
 

 
 
 
This next window will show a list of text templates for your current department.   Click the Add… button 
on the right side to add a new text template. 
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Enter the name and text for the template.  You can also specify if it is currently enabled or disabled. 
 

 
 
 
Now when you go to enter a customized text message, your newly created template will appear in the 
dropdown list. 
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Department Auto Text Messages 
Who’s Next has an Auto Text Message feature that automatically sends predefined text messages to 
students that opted-in during the sign-in process.  You can maintain your current department’s 
messages by going to Edit > Auto Text Message Maintenance…   
 
*Note* please note that this option is only available for users that have System Administrator privileges 
or who has access to the Texting > Can Maintain Auto Text Messages permissions for their current 
department. 
 

 
 
 
The Department Default Text Messages screen allows the user to add/edit all of the various predefined 
auto text messages.  Please note that due to the way our Text Messaging Service is designed, the system 
will automatically remove any apostrophes when you save the message. 
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 Help Message: The student will receive this help message when they reply by sending a letter “H” or 
“Help”.  *Note* this feature requires an additional component to be configured by your IT. 
 

 Leave Queue Message: The student can remove themselves from your queue by texting back “L” or 
“Leave”.  *Note* this feature requires an additional component to be configured by your IT. 

 

 Request More Time Message: The student can move themselves down the queue by texting back 
“M”.  The system will add ten (10) minutes to their sign-in time.  *Note* this feature requires an 
additional component to be configured by your IT. 

 

 More Time Limit Reached: Each department can be configured to limit how many times a student 
can request more time.  Once this limit is reached, the system will automatically send out this 
message.  *Note* this feature requires an additional component to be configured by your IT. 

 

 Status Message: The student can find out where they are in the queue, and their estimated wait 
time, by texting back “S”.  *Note* this feature requires an additional component to be configured by 
your IT. 

 

 Summon Message: This message will automatically go out when your staff clicks the Summon 
button. 

 

 Welcome Message: This message will automatically go out when the student successfully signs into 
your department and enters their cell phone number. 

 

 Within Specified Wait Time Message: The student will receive this message when their estimated 
wait time falls within a certain time limit.  *Note* this feature requires an additional component to 
be configured by your IT. 

 
 
This window allows you to enter up to 150 characters for the specified auto text message.  You can also 
enable or disable each message. 
 
*Note* Once a message is updated in the database, in order for the other workstations to see this 
change you will have to restart Who’s Next on those machines.   
 

Auto Text Messages Variable Shortcuts 
When the system is generated an auto text message, it can include these variables in the message.  
Simply add these shortcuts into the message for the correct information to appear in the outgoing text 
message. 
 

 [more_mins] = more minutes 

 [line_num] = number in line 

 [wait_time] = estimated wait time 
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Edit your school’s Terms of Services 
Who’s Next gives you the ability to enter your own Terms of Service.  You can find this option by going 
to Edit > Auto Text Message Maintenance… and then clicking on Terms of Service…  
 

 
 
You can copy-and-paste as much text as you need into this text box.  Click the Save button when you are 
finished. 
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When a Terms of Service is entered into Who’s Next, the next time a student goes to enter their cell 
phone number, then will now see a Terms of Service link.  Clicking this link will open another window 
that displays your school’s Terms of Service. 
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Document Manager 

The Document Manager is a special component that can be used to import electronic files into the 
Who’s Next database. The system will works by automatically saving a copy of the file into a shared 
directory located within your network.  This allows the user to move to different computers and, just so 
long as they have access to the same shared directory, they will be able to bring up that file from any 
computer. 
 
To run this component click on the Document Manager button on your toolbar or simply right-click on a 
student and select View Documents… 
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List of Files for a Student 
The Document Manager window allows you to enter a student’s ID number to search for their 
documents.  If you have access to multiple departments, and each one is running the Document 
Manager, then you can specify which department by clicking on the Departments drop-down list. 
 
You can click on any of the button on the right side to either Add, Edit or Delete or document, or click 
Open to open the file using it’s default application. 
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Adding a Document 
Clicking the Add… button allows you to add anew document for a student.  By default the system will 
automatically bring up the Select File window allowing you to browse for the file. 
 

 
 
 
Simply navigate to the folder that has your file, select it and click the Open button. 
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Once a file is opened, it will automatically fill in the name of the file in the Document File Name box. 
 

 
 
 
You can then enter a title and any notes for this file. 
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Allowing Access to a Document 
The area labeled Share With allows you to control who has access to each document.   
 

 
 

 Private: this option only allows you to access the file.  No other user within Who’s Next will be 
able to see or access this file. 
 

 All Users: this option allows all users within Who’s Next to access this file. 
 

 Current Department: this option allows all users within your current department to have access 
to the file. 

 

 Selected Users: this option allows you to specify particular users to have access to the file. 
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Opening a Document 
Clicking the Open Document link will open the file using it’s default application.  For example, if you are 
opening a text file (.txt extension), and your computer is set to use Notepad for these types of files, then 
Who’s Next will open this file using Notepad.  The same thing goes for Microsoft Word, Excel or any 
other electronic file imported into the Document Manager. 
 
Once a file is opened you can make any changes to it like you normally do.  If you save the changes, the 
changes will be saved to the same file that was imported into the Document Manager.  This means that 
the file on your server will be updated, allowing you to access these changes from any other computer. 
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Journal Entries Component 

The Jour Entries component in Who’s Next allows you to track inventory items that are borrowed by 
students.  This component offers a simple and efficient way to track all of your items and who has 
borrowed them. 

Setting Up your Journal Items 
Before you can start tracking your journal items, you must first create the items for your department.  
You can start this process by going to Edit > Journal Categories… 
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List All Journal Categories 
When you go to Edit > Journal Categories… the system will show you all of the Journal Categories for 
your department.  Can you click any of the buttons on the right side to Add, Edit, Delete or Recover 
items. 
 

 
 

Adding a New Journal Category 
When adding or editing a Journal Category, the system gives you the option to name the category and to 
set it as enabled. 
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Viewing the Journal Entries Switchboard 
To view the Journal Entries Switchboard simply click on the Journal Entries option at the bottom-left of 
the Who’s Next window.  Doing this will show all of your Journal Entries for your current department. 
 

 
 

 
 

Adding a Journal Item 
To add a new item simply click on the New Journal Entry button on the toolbar.  This will bring up the 
Adding Journal Entry window. 
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You have 3 options when adding or editing a Journal Entry: 

 Student ID: this option allows you to enter the Student ID (or search for) that will be borrowing 
this item. 
 

 Category: this option allows you to select what type of item is being borrowed.  These are the 
same categories that were built in the List All Journal Categories section on page 98. 

 

 Notes: this option allows you to enter any notes for this Journal Entry.  Use this option so or any 
of your staff can know why the student borrowed this item. 

 

Reporting on your Journal Items 
Who’s Next has 2 specific reports that allows you to retrieve your Journal Entries data.  Simply bring up 
the Reports Library (see the Reports section on page 48) and then click on the All Reports category.  
From there you will see a report named Closed Journal Entries Report and Open Journal Entries Report. 
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Fix Past Visit Hours Utility 

Who’s Next has a utility called Fix Past Visits Hours designed to find visits that pass a specified amount 
of time (either in hours or minutes).  The utility will then fix the visit’s sign-out time by adding the 
appropriate minutes to the student’s sign-in time. 
 
To run this utility go to Tools > Utilities > Fix Past Visit Hours… 

Search Criteria 
The Search Criteria tab allows you to search for past visits by offering a number of search parameters. 
 

 Beginning and Ending Date: these calendar controls allow you to specify the date range for the 
visits you are looking for.  If you do not want to specify a date range, check the No Date Range 
box. 
 

 Search by Hours: this option allows you to search for visits that pass a certain amount of hours. 
 

 Search by Minutes: this option allows you to search for visits that pass a certain amount of 
minutes. 
 

 Available Departments: this option allows you to select which departments you want to search 
for.   

 

 
 



105 | P a g e  
 

Search Results 
The Search Results tab shows you all of the visits that match your search criteria.  This window allows to 
you enter the exact number of minutes to add to the visit’s sign-in time to compute the sign-out time.  
You can also uncheck any visits if you do not want to update it. 
 
Click the Fix… button to fix the checked visits. 
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Commonly Asked Questions 

Who do I call to change my password? 
Every campus that uses Who’s Next has a designated user that is given System Administrative privileges.  
If a user needs to change his/her password we ask that they please contact the system admin first.  If 
they do not know who that person is, then they can call our support desk at 866.317.0256. 
 
 
I get an error message when trying to send an instant message. 
Please refer to the Instant Messages Fail section found in the Instant Messenger chapter of this 
document. 
 
 
How is the Who’s Next software licensed? 
Who’s Next is licensed on a per-user basis.  This means that for every counselor, advisor or staff person 
that needs to log in to track their students, they will each require one (1) license. 
 
Our software is not licensed on a concurrent user or a per-computer basis.  In fact, you can have Who’s 
Next installed on as many computers as you need. 
 
 
Can a campus purchase more licenses after the initial installation? 
Yes.  Once we receive a purchase order for your license(s), we will update our licensing server to reflect 
the new licenses.  You can then go to Edit > User Maintenance… to add a new user. 
 
Please see the User Maintenance chapter for more information. 
 
 
What do I do if one user leaves the campus (stops using Who’s Next) and I want to replace that license 
with a new user? 
We highly recommend you delete the old user’s account by going to Edit > User Maintenance… screen, 
selecting the user’s name and then clicking the Delete… button.  Doing this will not remove any of the 
user’s past visit information from the database; it will simply flag the user’s account as being deleted. 
 
One you delete the old user account, the system will then free up one license.  You should then be able 
to add a new account by clicking on the Add… button.  Please see the User Maintenance chapter for 
more information. 
 
 
Who’s Next prompts me for the data source properties every time I launch the software.  How can I 
stop the software from doing this? 
Your Microsoft Windows account does not have read/write permissions to the folder where the data 
source XML file is being stored.  Please refer to the Read/Write Permissions section found in the 
Connecting to the Who’s Next Database chapter. 
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Who’s Next does not appear to save my program option settings.  Every time I login it reverts back to 
its old settings. 
Please refer to the XML File Location and Read/Write Permissions sections found in the Program 
Options chapter of this document. 
 
 
 
 

  



108 | P a g e  
 

Contact Information 

Company Name: Blue Eon Solutions 
 

Mailing Address: 4007 McCullough Ave, Suite 458 
San Antonio, TX 78212 
USA 
 

Toll Free Phone Number: 1.866.317.0256 
 

Fax Number: 210.680.3363 
 

Email Address: support@blueeonsolutions.com 
 

Federal Tax ID Number: 01-0779240 
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